你所在的位置: 首页 > 华为认证 > HCDP >
最新开班 班级 报名状态
9月16日 HCNP-R&S(含初级) 热招中
9月18日 RHCSA脱产班 热招中
9月25日 HCNA-Cloud Service 热招中
9月25日 HCNA-Cloud Service 热招中
9月30日 HCNA-R&S周末班 热招中
10月31日 HCNP-storage脱产班 热招中
10月23日 HCNA-storage脱产班 热招中
10月20日 HCNP-R&S脱产班 热招中
10月10日 HCIE-R&S脱产班 热招中
10月9日 HCNA-R&S脱产班 热招中
  • 博赛网络ICT就业班热招中
  • 博赛推出Oracle OCM实战课程

华为路由器和交换机配置地址转换

时间:2013-11-08 11:30 作者:Superthink 点击:

一. 端口:
路由器——ethernet(以太口)、Serial(串口)、loopback(虚拟端口)
交换机——ethernet、vlan、loopback
注意:交换机默认其24个端口全在vlan 1里面,交换机在给vlan配了ip之后就具有路由器的功能了。 另一个需要注意的是,所用的端口是否被shutdown了,如果被shutdown了,需要进入相应的端口执行undo shutdown。
二. 配置ip
除了交换机的以太口不可以配置ip外,其他端口都可以,配置方法相同。
[Quidway] interface *(所要配置的端口,如vlan 1)
[Quidway-*]ip add *.*.*.*(ip) *.*.*.*(掩码)/*(掩码位数,一般只在路由器上适用)
三. NAT 上网(此命令是在VRP版本为3.4的路由器上测试的,在其他版本上是否适用,未经考察)组网图:
R1
E0/2
E0/3
E0/1
E1:192.192.169.*/24
E0:192.168.2.1/24
Ip:192.168.2.10/24
网关:192.168.2.1
Ip:192.168.2.11/24
网关:192.168.2.1
Ip:192.168.2.12/24
网关:192.168.2.1
Ip:192.168.2.13/24
网关:192.168.2.1
PCA
PCB
PCC
E0/4
To internet
PCD
S1
E0/5
NAPT工作过程:P19
1.用地址池的方法上网:
首先配置路由器的接口的ip地址,
然后配置地址转换,把所有内网地址转换成所配置的地址池中的地址,参考命令如下:
[R1]acl number 2000 //在vrp为3.4的路由器上,2000-2999表示basic acl
[R1-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255(地址掩码的反码)
[R1-acl-basic-2000]rule deny source any
#这个访问控制列表定义了IP源地址为192.168.2.0/24的外出数据包
[R1]nat address-group 1(地址池的组号)192.192.169.10 192.192.169.15
#这条命令定义了一个包含6个公网地址(10~15)的地址池,地址池代号为1
[R1] interface e 1
[R1-Ethernet1] nat outbound 2000(acl的编号) address-group 1 (地址池的代号)
[R1]ip route-static 0.0.0.0 0.0.0.0 192.192.169.1 (千万不要忘记这一步,!)
#上面设置了路由器的E0和E1端口IP地址,并在路由表中添加缺省路由。
2.共用一个ip上网
首先配置路由器的接口的ip地址,参考命令如下:
system   
[Router]sysname R1
[R1]interface e0
[R1-Ethernet0]ip add 192.168.2.1 24
[R1]interface e1
[R1-Ethernet1]ip add 192.192.169.10 24 //这里假设出口ip是192.192.169.10
然后配置地址转换,参考命令如下:
[R1]acl number 2000 //在vrp为3.4的路由器上,2000-2999表示basic acl
[R1-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255(地址掩码的反码)
[R1-acl-basic-2000]rule deny source any
#这个访问控制列表定义了IP源地址为192.168.2.0/24的外出数据包
[R1] interface e 1
[R1-Ethernet1]nat server protocol tcp global 192.192.169.10(E1的ip) inside 192.168.2.1(内网网关E0的ip)
[R1-Ethernet1] nat outbound 2000(acl的编号)
[R1]ip route-static 0.0.0.0 0.0.0.0 192.192.169.1
#上面设置了路由器的E0和E1端口IP地址,并在路由表中添加缺省路由。
注:有的组网图可能会复杂一些,比如交换机上划分了vlan,需要在路由器上添加到交换机的路由

四、配置路由
1.默认路由
[Quidway]ip route-static 0.0.0.0(目的地址)0.0.0.0(地址掩码)*.*.*.*(下一条地址)
2.静态路由
[Quidway]ip route-static *.*.*.*(目的地址)*.*.*.*(地址掩码)*.*.*.*(下一条地址)
3. rip(交换机和路由器的配置相同)
[Quidway]rip
[Quidway-rip]network *.*.*.*(所要启动rip协议的端口的网络号)
4. ospf(交换机和路由器的配置相同)
[Quidway]router id *.*.*.*
[Quidway]ospf
[Quidway-ospf]area * (启动ospf的自治区域)
[Quidway-ospf-area-0.0.0.*] network *.*.*.*(所要启动rip协议的端口的网络号)*.*.*.*(网络掩码的反码)
注:要注意交换机/路由器对应端口所在的自治区域。帧在网络通信中的变化


端口镜像:将某些指定端口(出或入方向)的数据流量映射到监控端口,以便集中使用数据捕获软件进行数据分析
[S1]inter e 0/13
[S1-Ethernet0/13]port link –type Trunk
[S1-Ethernet0/13]port trunk permit VLAN 2 3
这样E0/13既属于VLAN2又属于VLAN3,“Tagged”表示从该端口通过的保温都要打上IEEE802.1q标记,用于标记该报文所属的VLAN。
(2005-07-11 23:26:23) 海醒

区域内,每台路由器描述的是自己能够确保正确的信息--自己周边的网络拓扑结构--无论路由器位于网络中什么位置,都可以准确无误得接收到全网的拓扑结构图;OSPF 根据收集到的链路状态用最短路径树算法计算路由,从算法上本身保证了不会生成自环路由;当网络拓扑结构发生变化时,会有一台或多台路由器感知到这一变化,重新描述网络拓扑结构,并将其通知给其它路由器,每个路由器收到更新信息后,都会立即重新运行最短路径树算法,得到新的路由。
区域间,通过ABR将一个区域内已计算出的路由封装成Type3类的LSA发送到另一个区域中来传递路由信息。此时的OSPF是基于D-V算法的。为消除自环,所有ABR将本区域内的路由信息封装成LSA后统一发送给骨干区域,再由骨干区域将这些信息发送给其他区域,骨干区域内每一条LSA都确切知道生成者信息(所有区域必须和骨干区域相连,骨干区域自身也必须是连通的)。所以就不会产生路由自环。
服务器192.192.169.200 我要用的ip:192.192.169.113;网关:192.192.169.1
附:

display ip routing

ip route-static *.*.*.* (目标ip) *.*.*.* (掩码) *.*.*.*(下一条ip)

ip route *.*.*.* (目标ip) *.*.*.* (掩码) *.*.*.*(下一条ip)

undo ip route-static *.*.*.* (目标ip) *.*.*.* (掩码) *.*.*.*(下一条ip)

import-route static 将静态路由引入ospf

display ospf lsa

假如S1上的vlan3与R1的e0/0相连,要设定其Metric值为100

[S1]inter vlan3

[S1-Vlan-interface3]ospf cost 100

[R1]inter e 0/0
[R1-Ethernet0]ospf cost 100
[R1]tracert *.*.*.* (目标ip)

1 ip1

2 ip2

3 ip3

说明R1到达目标先到ip1再到ip2再到ip3(目标),由此可得出最短路径树
查看交换机的MAC地址: display arp

(责任编辑:Superthink)

评论列表(网友评论仅供网友表达个人看法,并不表明本站同意其观点或证实其描述)